Project Undertow #388

Dominicnicklyn

Active Member
This sounds like some of the issues I was having. The solution to my goblin's issues was
1. poor connection on the connectors under the fusebox, (reseating the connectors fixed this)
2. bad data connector at the power steering (bought a connector from an auto recycle yard, soldered it on)
3. replaced the power steering unit with used one.
I also cleaned every ground wire and retorqued all 3 of my grounding points, which have a bunch of ground wires on each one.

When your data is flowing enough to move the throttle butterfly, I wonder if jumping the starter motor would allow it to run. On my LSJ, I ran the purple starter wire into the cabin, so I could connect it to accessory 12V power, and jump the starter quickly, while in traffic. I had to do this for about 6 months, as it took that long for me to debug my data issues.
Yes, I was thinking about this while laying in bed last night.

I'm starting to belive that I solved the original issue and now I have a bad ECM ground. I only lose coms with the ECM atm.

I'll check the fuse block plugs, but I've already set them in 3 different times believing they weren't making good contact. (Had to jb weld some plastics due to over tightening them)

I've done all of your solutions above. Even swaped ecm/bcm/ignition from another same model lsj.

I'll dive deeper when I get home from work.
 

Gtstorey

Goblin Guru
I had to unplug the individual wires from the fuse box to plugs and tighten the individual connections to get mine to stop having intermittent issues. And the more you have messed with the plugs, the more likely you are to have this problem.
 

Gtstorey

Goblin Guru
But I would still start by confirming your missing “black” ECM wire is a ground and reconnecting if it is. I don’t expect any of the ECM to be unnecessary.
 
Top